We recommend using Google Chrome for SWITCH

The current DA-Desk application requires Internet Explorer (IE) compatibility view settings to be enabled.

This is to ensure that the website will be displayed correctly, as if you were viewing them in a previous versions of Internet Explorer.

Unfortunately, this setting interferes with SWITCH (even with the latest version of IE) therefore we recommend Google Chrome or any of the other browsers listed below.

Download one of these browsers and you’ll be on your way.